T300 Issues and re-calibration

Discussion in 'Sim Racing Systems & Troubleshooting' started by SPL Racing, Jul 16, 2016.

  1. SPL Racing

    SPL Racing Professional Gold Member

    Posts:
    1,017
    Likes:
    1,348
    PSN ID
    SPL_Racing
    I have been having some issues with the FFB and start up calibration of my T300RS recently. On start up the wheel would not spin to the left first but would only spin violently to the right and continue to do so. The only fix I found was to manually turn the wheel to the left so it would calibrate correctly so I could use it. The FFB seemed to be getting weaker with each race and I didn't want the down time of sending off the wheel to be fixed or replaced so I found this download that fixed it right up.

    You need to update the firmware first to make sure you are running the newest update http://ts.thrustmaster.com/download/pub/webupdate/T500RS/T300RS_Firmware_Update_Procedure_V25.pdf

    Then download the Zip file with instruction PDF for installation
    http://projectcars.club/wp-content/uploads/tools/T300-Calibration.zip

    After running both of these it fixed the start up calibration and the FFB returned to full strength. So if you are having issues with your T300 then try this first before sending the wheel back.
  2. garyw61

    garyw61 Gary Gold Member Super ROOZ

    Posts:
    1,910
    Likes:
    1,241
    PSN ID
    garyw61
    This is only a short term fix unfortunately SPL. You will eventually have to return it for a replacement. If it is still under warranty, I would do this before it runs out.
    SPL Racing likes this.
  3. SPL Racing

    SPL Racing Professional Gold Member

    Posts:
    1,017
    Likes:
    1,348
    PSN ID
    SPL_Racing
    That doesn't sound good. I might look into it
  4. garyw61

    garyw61 Gary Gold Member Super ROOZ

    Posts:
    1,910
    Likes:
    1,241
    PSN ID
    garyw61
    Here is the official response I got from Thrustmaster Support:

    "The motor calibration tool you inquired about can be found at the link below.

    If you still can, we recommend having the wheel replaced at the store you bought it from, as the motor calibration tool is only a temporary solution and it's not even guaranteed to work."

    Ever since I have had my replacement, I have never run FFB higher than 70. Haven't had any issues since.
    Spidey_11 likes this.
  5. Benjamin J Smith

    Benjamin J Smith Professional Gold Member

    Posts:
    1,898
    Likes:
    1,623
    Wow can't believe how many wheels this 1 game has broke, would love too see the number between the G29's and T300's
  6. incey

    incey Professional Gold Member

    Posts:
    1,731
    Likes:
    1,111
    PSN ID
    incey
    I had two of them fail before I demanded a refund. It was costing me a packet mailing them back each time. Although the G29 I have now doesn't feel as good it hasn't let me down.
  7. COME_AND_GET_ME7

    COME_AND_GET_ME7 Professional

    Posts:
    1,877
    Likes:
    1,555
    T300's from what I've seen have a > 50% failure rate within the first 6 months. I believe AOCleaner is onto his third or fourth. On the other hand I've only heard of one or two issues with the G29. Going with the G29 over the T300 was a no brainer for me. 1) T300's go for $800 over here twice that of a G29. 2) G29 comes with a superior pedal set out of the box. 3) G29 comes with a 2 year warranty. The only thing a T300 has over the G29 is FFB and if you've never tried one you'll think the G29 still feels great when you put the correct FFB settings in.
    JonoStan96 likes this.
  8. fezza

    fezza Team Driver

    Posts:
    383
    Likes:
    280
    PSN ID
    FeZZa_21
    anyone got a copy of the calibration tool? the pcars link doesn't work. this issue has started happening to my over 2yr old wheel, so out of warranty to send back for repairs.
  9. garyw61

    garyw61 Gary Gold Member Super ROOZ

    Posts:
    1,910
    Likes:
    1,241
    PSN ID
    garyw61
  10. ShootSho7t

    ShootSho7t Rookie

    Posts:
    37
    Likes:
    41
    PSN ID
    shoootshoooooooot
    Is this calibration issue and the weak force feedback issue are inter-related or they are a separate issue ?

    Damn, I had both, tried update the firmware, it still went crazy banging to the right but I can set the wheel center manually and it stopped that crazy :):):):). Kind of okay.

    But the force feedback is still weak as none, tried on projectcars and assetto corsa, same, very weak ffb near the center area, but still has a strong ffb in a spin or the wheel goes over 270 degree.

    I had that wheel around 2 yrs...is it time for a new base....geez, got the h shifter and an add on pedal ........cant just switch to another brand eh..

    If anyone has any suggestion or anything , please feel free to share, thanks...
  11. SPL Racing

    SPL Racing Professional Gold Member

    Posts:
    1,017
    Likes:
    1,348
    PSN ID
    SPL_Racing
    Yeah i'm pretty sure they are related. I just sent mine back for a replacement as it never got better. I had a 2 year warranty so just snuck in under that for replacement. I'm keep my ffb down much lower this time to try and make the wheel last longer. But yeah it could be time for a new one.
  12. ShootSho7t

    ShootSho7t Rookie

    Posts:
    37
    Likes:
    41
    PSN ID
    shoootshoooooooot
    Sad but true.

    Will do a bootloader and that calibration tool for the last try, before getting the base.

    I'm in NZ, can't really find a base unit only for sale.... need to try my luck with the reseller with an indent order or might need to go for online overseas or Amazon etc
  13. SPL Racing

    SPL Racing Professional Gold Member

    Posts:
    1,017
    Likes:
    1,348
    PSN ID
    SPL_Racing
    Yeah I got to the point where I was having to re-calibrate with the software then have to go into the control panel to re-centre the wheel before every session. I was doing it in the PS main screen doing the turn both ways then pushing the 3 buttons but that seemed to make the ffb drop out even sooner, if I did it in the control panel it didn't put the extra strain on the wheel and sometimes I could get through a whole race.
    ShootSho7t likes this.
  14. ShootSho7t

    ShootSho7t Rookie

    Posts:
    37
    Likes:
    41
    PSN ID
    shoootshoooooooot
    No base unit only in Auckland, and store offered me NZD 799 for the T300 Ferrari Integral wheel package....and offer accepted...lol=
    Just need to sell off the t3pa now cus I got the t3pa pro.......money spent and considered that as a wheel upgrade as the base is the same....

    So, did u guys follow the Jacks Spades ffb setting , with the ffb below 70 or 100? (with forced cooling fan mode on)
  15. garyw61

    garyw61 Gary Gold Member Super ROOZ

    Posts:
    1,910
    Likes:
    1,241
    PSN ID
    garyw61
    jack of spades for me. FFB = 70%, Tyre force = 100
  16. ShootSho7t

    ShootSho7t Rookie

    Posts:
    37
    Likes:
    41
    PSN ID
    shoootshoooooooot
    Thanks.

    with ffb 70, tf 100, it went smooth without clipping, but the ffb faded completely after 5 laps of Imola, using the rock bunny gt86.

    Need to do a reconnection.

    just did 2 set of 7 laps with, ffb 65 and tf 85, all good.

    I am using the jack spades without soft clip setting.
  17. JonoStan96

    JonoStan96 Professional Gold Member

    Posts:
    7,875
    Likes:
    7,558
    PSN ID
    N64TheStig007 (J.Stankowski)
    Some time between Origin and the F1 race it has broken, doing that stupid recalibration thing mentioned in the first post.
    Had it less than a year so I’m not happy at all.
  18. Inzyman

    Inzyman Rookie

    Posts:
    33
    Likes:
    27
    PSN ID
    Cranew1
    Just took my first T300 back last week. Any drama's with this one and I will be looking at something else!
  19. Easyprey007

    Easyprey007 Rookie Gold Member

    Posts:
    217
    Likes:
    208
    PSN ID
    Easyprey007
    Hi my T300 did the spastic calibration it went mental.
    I was so happy when I re calibrated for the motor and it fixed the t300
    It now calibrates perfectly. Woo hoo

    I tested it on my rig ps4 and I had no throttle at all
    connected it back up to the computer to check for any updates and it was on the latest.
    Then I found that in the boxes in the program Clutch ... brake....throttle....
    That the clutch box is rising when you press the throttle and not the throttle box as it should.
    Hope I made sense the throttle is working as a clutch.
    So Im stuck until I can work it out

    Any ideas?
  20. CAB77

    CAB77 Team Driver Gold Member

    Posts:
    367
    Likes:
    386
    PSN ID
    CAB-77_
    Press and hold the mide button the light will change.