Csl elite pedal problems

Discussion in 'Sim Racing Systems & Troubleshooting' started by PaulCox, Mar 27, 2020.

  1. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    Hey guys, any one have issues with the pedals jumping around crazy on pcars 2 in calibration. Then when I finally get it right I jump in the car and my break never fully releases . Then the accelerator jumps between half and full no matter the pressure I use.
    Cheers
  2. xlxy90

    xlxy90 Professional Gold Member

    Posts:
    1,046
    Likes:
    1,067
    PSN ID
    xlxy90
    check to make sure the cord isn't pinching somewhere on your rig and has worn through
    PaulCox likes this.
  3. Hatfield

    Hatfield Teams Championship Chairman Team Raceonoz Gold Member Super ROOZ

    Posts:
    14,101
    Likes:
    11,552
    PSN ID
    DRZ-Hatfield
    does it happen in other games?
    PaulCox likes this.
  4. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    I’ll have to check lol
  5. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    Thanks mate..will rip em off tomorrow n have a look
  6. beakeroo

    beakeroo Professional Gold Member

    Posts:
    1,644
    Likes:
    1,267
    PSN ID
    beakeroo Steam ID: beakeroo
    I did have this exact problem Paul. Are you using a metal rig? I had to isolate the pedals with a rubber mat as static electricity build up was the issue. I ended up isolating the rig as well.

    Cue isolation joke -
    PaulCox likes this.
  7. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    Yer I use the gt ultimate rig...does that mean try add a rubber mat before I bolt them back down?
    beakeroo likes this.
  8. beakeroo

    beakeroo Professional Gold Member

    Posts:
    1,644
    Likes:
    1,267
    PSN ID
    beakeroo Steam ID: beakeroo
    Same rig as myself, yes I put a rubber mat beneath the pedals and rubber washers on the bolts that attached the pedals to the rig.
    PaulCox likes this.
  9. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    Cables are perfect, f1 seems to be ok. Hoping to get some contact cleaner tomorrow then screw it back down on a rubber mat n hope for the best. Thanks for the help guys.
  10. PaulCox

    PaulCox Team Driver Gold Member

    Posts:
    730
    Likes:
    592
    PSN ID
    coxy383420
    Half a can of contact cleaner seems to have done the job